Workspace Timeout?

Jun 16, 2012 at 5:16 AM

Hello. I want to thank you for creating such a great database for .NET. I have been looking for a good one forever, and this is the one I decided on, based on the great features. 

I am just starting to code an application using the database, but I am having an issue: when I open a workspace, and the program I'm running does not dispose it soon enough, I get an exception about the workspace timing out. Should the workspace be closed as soon as possible, or is there a property to control the timeout, and/or possibly make in infinite? Any help is appreciated.

 

Thank you,

 

Mike

Coordinator
Jun 16, 2012 at 1:08 PM

Hello,

you can keep a workspace open as long as you need to, there is no limitation. Workspace timeout serves as a safety limit - to release resources when workspace is not disposed due to some error.

There is a property called "DefaultWorkspaceTimeoutSeconds" which you can override in your app.config/web.config to change the global timeout. See app.config in IOG source root for all available settings. See ObjectBenchmark project as an example of how to modify IOG settings from your applications config.

Another option is to define timeout for individual workspace, when performing OpenWorkspace.

I hope this answers your question.

Best regards,

Nenad Sabo

DefaultWorkspaceTimeoutSecond
Jun 17, 2012 at 2:45 AM

Hello. Thank you for the quick response. I am modifying the timeout from OpenWorkspace as you suggested. Is it possible to turn the timeout off completely? Or should I turn the timespan up extremely high?

Coordinator
Jun 17, 2012 at 7:38 AM
There is no setting for indefinite timeout, so the only option is to set to large number of seconds, which will not be reached in practice, like 1000 years.

-----Original Message-----
From: "vectorman"
Sent: 17/06/2012, 3:45 AM
To: [email removed]
Subject: Re: Workspace Timeout? [iog:359814]


From: vectorman

Hello. Thank you for the quick response. I am modifying the timeout from OpenWorkspace as you suggested. Is it possible to turn the timeout off completely? Or should I turn the timespan up extremely high?